• Mike Gabriel's avatar
    Rework nxagent and nxproxy wrapper scripts. · 5934d03e
    Mike Gabriel authored
      o Install nxagent/nxproxy executables into multi-arch path.
      o Fake libNX_X11.so* as $LIBDIR/nx-X11/libX11.so*.
      o Allow injecting different $NXAPP containing the executable name.
    
      o For e.g. x2goagent this requires the following changes:
    
        - Move x2goagent symlink from /usr/lib/x2go/bin/x2goagent to
          $LIBDIR/nx/bin/x2goagent
        - Replace /usr/bin/x2goagent by a two-liner...
    
        ```
        #!/bin/sh
    
        export NXAPP=x2goagent
        nxagent
        ```
    5934d03e
nxproxy.install 100 Bytes