• Mihai Moldovan's avatar
    nx{comp{,ext,shad},proxy}: try really hard to find makedepend. Do not fail if it is not available. · 06b51cc3
    Mihai Moldovan authored
    Also rename to account for dependency changes:
        - 0070_nxcomp_use-MAKEDEPEND-in-path.full+lite.patch =>
          0410_nxcomp_use-MAKEDEPEND-in-path.full+lite.patch
        - 0071_nxcompext_use-MAKEDEPEND-in-path.full+lite.patch =>
          0610_nxcompext_use-MAKEDEPEND-in-path.full+lite.patch
        - 0072_nxcompshad_use-MAKEDEPEND-in-path.full+lite.patch =>
          0611_nxcompshad_use-MAKEDEPEND-in-path.full+lite.patch
        - 0073_nxproxy_use-MAKEDEPEND-in-path.full+lite.patch =>
          0612_nxproxy_use-MAKEDEPEND-in-path.full+lite.patch
        - 0074_nxcomp_use-dynamiclib-flag-on-OS-X.full+lite.patch =>
          0613_nxcomp_use-dynamiclib-flag-on-OS-X.full+lite.patch
        - 0075_nxcompshad_use-dynamiclib-flag-on-OS-X.full+lite.patch =>
          0614_nxcompshad_use-dynamiclib-flag-on-OS-X.full+lite.patch
        - 0610_nxcompext_use-correct-library-naming-scheme-on-OS-X.full+lite.patch
          =>
          0620_nxcompext_use-correct-library-naming-scheme-on-OS-X.full+lite.patch
        - 0611_nxcompshad_use-correct-library-naming-scheme-on-OS-X.full+lite.patch
          =>
          0621_nxcompshad_use-correct-library-naming-scheme-on-OS-X.full+lite.patch
    06b51cc3
0420_nxcomp_use-correct-library-naming-scheme-on-OS-X.full+lite.patch 2.29 KB
Description: Use the correct library naming scheme on OS X. It differs from other UNIX-based systems.
Author: Clemens Lang <cal@macports.org>

--- a/nxcomp/Makefile.in
+++ b/nxcomp/Makefile.in
@@ -91,9 +91,17 @@ DEPENDINCLUDES = -I/usr/include/c++ -I/u
 LIBRARY = Xcomp
 
 LIBNAME    = lib$(LIBRARY)
+ifeq ($(shell uname),Darwin)
+LIBFULL    = lib$(LIBRARY).$(VERSION).dylib
+LIBLOAD    = lib$(LIBRARY).$(LIBVERSION).dylib
+LIBSHARED  = lib$(LIBRARY).dylib
+LIBFLAGS   = -install_name $(libdir)/$(LIBLOAD) -compatibility_version $(LIBVERSION) -current_version $(VERSION)
+else
 LIBFULL    = lib$(LIBRARY).so.$(VERSION)
 LIBLOAD    = lib$(LIBRARY).so.$(LIBVERSION)
 LIBSHARED  = lib$(LIBRARY).so
+LIBFLAGS   =
+endif
 LIBARCHIVE = lib$(LIBRARY).a
 
 LIBCYGSHARED  = cyg$(LIBRARY).dll
@@ -232,7 +240,7 @@ COBJ   = $(CSRC:.c=.o)
 CXXOBJ = $(CXXSRC:.cpp=.o)
 
 $(LIBFULL):	 $(CXXOBJ) $(COBJ)
-		 $(CXX) -o $@ $(LDFLAGS) $(CXXOBJ) $(COBJ) $(LIBS)
+		 $(CXX) -o $@ $(LDFLAGS) $(LIBFLAGS) $(CXXOBJ) $(COBJ) $(LIBS)
 
 $(LIBLOAD):	 $(LIBFULL)
 		 rm -f $(LIBLOAD)
@@ -278,9 +286,9 @@ install.lib: all
 	./mkinstalldirs $(DESTDIR)${libdir}
 	./mkinstalldirs $(DESTDIR)${includedir}/nx
 	$(INSTALL_DATA) $(LIBFULL)              $(DESTDIR)${libdir}
-	$(INSTALL_LINK) libXcomp.so.3           $(DESTDIR)${libdir}
-	$(INSTALL_LINK) libXcomp.so             $(DESTDIR)${libdir}
-	$(INSTALL_DATA) libXcomp.a              $(DESTDIR)${libdir}
+	$(INSTALL_LINK) $(LIBLOAD)              $(DESTDIR)${libdir}
+	$(INSTALL_LINK) $(LIBSHARED)            $(DESTDIR)${libdir}
+	$(INSTALL_DATA) $(LIBARCHIVE)           $(DESTDIR)${libdir}
 	$(INSTALL_DATA) NX*.h                   $(DESTDIR)${includedir}/nx
 	$(INSTALL_DATA) MD5.h                   $(DESTDIR)${includedir}/nx
 	echo "Running ldconfig tool, this may take a while..." && ldconfig || true
@@ -293,9 +301,9 @@ uninstall.bin:
 
 uninstall.lib:
 	$(RM_FILE) $(DESTDIR)${libdir}/$(LIBFULL)
-	$(RM_FILE) $(DESTDIR)${libdir}/libXcomp.so.3
-	$(RM_FILE) $(DESTDIR)${libdir}/libXcomp.so
-	$(RM_FILE) $(DESTDIR)${libdir}/libXcomp.a
+	$(RM_FILE) $(DESTDIR)${libdir}/$(LIBLOAD)
+	$(RM_FILE) $(DESTDIR)${libdir}/$(LIBSHARED)
+	$(RM_FILE) $(DESTDIR)${libdir}/$(LIBARCHIVE)
 	$(RM_FILE) $(DESTDIR)${includedir}/nx/NXalert.h
 	$(RM_FILE) $(DESTDIR)${includedir}/nx/NX.h
 	$(RM_FILE) $(DESTDIR)${includedir}/nx/NXmitshm.h